HomePhabricator

Update the API version used by the lib

Authored by CLOVIS on Mar 5 2020, 3:37 PM.

Description

Update the API version used by the lib

Merge branch 'update-api' into 'master'

  • Update the API
  • Create a script that checks if its up-to-date
  • Create a Docker image to run a CI job with that script
  • Create a CI job that tests if the API is up-to-date
  • Use that image in the CI job

See merge request wildfyre/lib!5

Merged Changes

CommitAuthorDetailsCommitted
1a834518bd97CLOVIS
ci(docker): Added Docker image to run the API up-to-date-ness script 
Feb 29
4967fea30f85CLOVIS
ci(api): Added test in GitLab CI to see if the API is up-to-date or not 
Feb 29
0e730f443251CLOVIS
feat(api): Created script option 'is-uptodate' that fails when the API is not… 
Feb 29
c6bb5a6d92a0CLOVIS
refactor(api): Refactored multiple calls to lsof into a function to avoid code… 
Feb 29
6181e9673e47CLOVIS
build(api): Updated API to commit 39ac13b691aa60a256822a1261edbc8762438f15 
Feb 29